Guru3D.com Forums

Go Back   Guru3D.com Forums > Videocards > Videocards - AMD Radeon Catalyst Drivers Section
Videocards - AMD Radeon Catalyst Drivers Section In this section you can discuss everything AMD Catalyst related. Catalyst drivers are for all AMD based graphics cards and APUs.



Reply
 
Thread Tools Display Modes
Old
  (#26)
OnnA
Ancient Guru
 
OnnA's Avatar
 
Videocard: Nitro Fiji-X HBM 1150/570
Processor: ZEN x8 k17 + Nepton 280L
Mainboard: ASUS Crosshair VI Hero
Memory: 16GB 3200 CL15 1T Ripjaws
Soundcard: SB-z Nichicon + Wood 5.1
PSU: Seasonic-X 750W Platinum
Lightbulb 05-19-2017, 13:30 | posts: 3,131 | Location: HolyWater Village

Quote:
Originally Posted by prazola View Post
Uhm...29-61. Is this vsync related?
In FH3 better to have VS On + Smooth On
It's Driver related...
It's WDDM 2.2 in CU related...
   
Reply With Quote
 
Old
  (#27)
passenger
Master Guru
 
Videocard: Sapphire RX580 8GB
Processor: AMD FX6300 @4.5GHz
Mainboard: ASUS Sabertooth 990FX 2.0
Memory: 12GB
Soundcard: X-Fi Titanium
PSU: Corsair HX520W
Default 05-19-2017, 14:16 | posts: 237

I got shadow artifacts in Rise of Tomb Raider under Dx12 only when using SSAA but it's not biggie, can use other aa. But the other thing is funny under Win7 latest gpu-z and Sapphire TRIXX can measure only up to 4096MB of vram, don't know what's that about?!?
In Win10 it's all fine.
   
Reply With Quote
Old
  (#28)
mtrai
Master Guru
 
Videocard: PowerColor RX 480 Red Dev
Processor: Skylake I5 6600K
Mainboard: ASUS Z170-A
Memory: G.Skill Ripjaw V 2x8 3200
Soundcard:
PSU: evga supernova 1050 gs
Default 05-19-2017, 15:32 | posts: 774 | Location: Panama City Beach, FL, USA

/edit deleted custom bios issue.

Last edited by mtrai; 05-19-2017 at 18:15.
   
Reply With Quote
Old
  (#29)
OnnA
Ancient Guru
 
OnnA's Avatar
 
Videocard: Nitro Fiji-X HBM 1150/570
Processor: ZEN x8 k17 + Nepton 280L
Mainboard: ASUS Crosshair VI Hero
Memory: 16GB 3200 CL15 1T Ripjaws
Soundcard: SB-z Nichicon + Wood 5.1
PSU: Seasonic-X 750W Platinum
Lightbulb 05-19-2017, 16:05 | posts: 3,131 | Location: HolyWater Village

Today was a good day ... until i've launched Forza H 3
Yeah 530Lev -> Forzathon is completed now (Porshe Carrera GT )

OMG

New Win_X CU = Rewriten Driver for WDDM 2.2
ZEN Launch
Preparing VEGA and Vega Pro



But to stay Positive ! we have at last new WDDM 2.2 Working 17.5.1

Last edited by OnnA; 05-19-2017 at 16:07.
   
Reply With Quote
 
Old
  (#30)
Romulus_ut3
Master Guru
 
Videocard: HD 7950 Vapor-X 3GB Boost
Processor: Core i5 3470 @ 3.8 GHz
Mainboard: Gigabyte GA-Z77-D3H Rev 1
Memory: Vengeance 2x4GB 1600 CL9
Soundcard: Creative 24 bit Live! 5.1
PSU: Thermaltake 650W Smart
Default 05-19-2017, 16:34 | posts: 523 | Location: Bangladesh

So, there's absolutely no reason for a HD 7000 owner to download this, right? I don't have Prey, btw.
   
Reply With Quote
Old
  (#31)
OnnA
Ancient Guru
 
OnnA's Avatar
 
Videocard: Nitro Fiji-X HBM 1150/570
Processor: ZEN x8 k17 + Nepton 280L
Mainboard: ASUS Crosshair VI Hero
Memory: 16GB 3200 CL15 1T Ripjaws
Soundcard: SB-z Nichicon + Wood 5.1
PSU: Seasonic-X 750W Platinum
Talking 05-19-2017, 16:41 | posts: 3,131 | Location: HolyWater Village

Quote:
Originally Posted by Romulus_ut3 View Post
So, there's absolutely no reason for a HD 7000 owner to download this, right? I don't have Prey, btw.
Always Download and test New Drivers
Maby it will be Best For You (who knows)
   
Reply With Quote
Old
  (#32)
Romulus_ut3
Master Guru
 
Videocard: HD 7950 Vapor-X 3GB Boost
Processor: Core i5 3470 @ 3.8 GHz
Mainboard: Gigabyte GA-Z77-D3H Rev 1
Memory: Vengeance 2x4GB 1600 CL9
Soundcard: Creative 24 bit Live! 5.1
PSU: Thermaltake 650W Smart
Default 05-19-2017, 17:34 | posts: 523 | Location: Bangladesh

Good point.
   
Reply With Quote
Old
  (#33)
Warkratos
Newbie
 
Warkratos's Avatar
 
Videocard: RX470 Asus Strix OC
Processor: Intel Core i5 7600
Mainboard: Gigabyte B150M-GAMING 3
Memory: Corsair 8Gb DDR4
Soundcard: Realtek
PSU: PCYES Shocker 500W
Default 05-19-2017, 19:53 | posts: 36

Quote:
Originally Posted by KissSh0t View Post
How would I contact AMD about issues with the ASUS ROG Radeon RX 470 Strix Gaming OC 4GB losing connection to monitor at default clocks when playing video games?

I remedied the issue by underclocking and undervolting, but I would like to have the issue fixed properly by Asus via a bios update, I am unable to modify the bios of this card.

How do I contact someone at AMD that can get something actually done about this? I have tried contacting Asus twice but they basically ignore any type of actual request for help, I am hoping getting someone from AMD to bring up this issue with Asus will get something going with this issue that plagues this specific video card model.
I have the same issue with the same card.
   
Reply With Quote
Old
  (#34)
Romulus_ut3
Master Guru
 
Videocard: HD 7950 Vapor-X 3GB Boost
Processor: Core i5 3470 @ 3.8 GHz
Mainboard: Gigabyte GA-Z77-D3H Rev 1
Memory: Vengeance 2x4GB 1600 CL9
Soundcard: Creative 24 bit Live! 5.1
PSU: Thermaltake 650W Smart
Default 05-19-2017, 20:47 | posts: 523 | Location: Bangladesh

Have you tried Asus' official forums? Though I suspect it'll be a waste of time.

Here's the experience with Asus' technical support my friend has had: he owns a pair of GTX 980 Ti STRIX and has a 165 Hz monitor. To drive the 165 Hz refresh rate, it requires higher voltage which apparently is locked out from within the BIOS and his card is unstable if he uses the OC mode BIOS setting which has slightly higher operating frequency than the regular gaming BIOS and further overclocking at 165 Hz is out of the frame .
   
Reply With Quote
Old
  (#35)
KissSh0t
Ancient Guru
 
KissSh0t's Avatar
 
Videocard: ASUS RX 470 Strix Gaming
Processor: AMD FX 8320
Mainboard: ASUS M5A97 R2.0
Memory: G.Skill Ripjaws X F3 8GB
Soundcard: X-Fi XtremeMusic
PSU: Corsair HX650W
Default 05-19-2017, 23:56 | posts: 5,088 | Location: 0.0.0.0

Quote:
Originally Posted by Warkratos View Post
I have the same issue with the same card.
I sent a help request last night through the AMD driver reporting thingy... I am hoping to bring the issue up with AMD so they can make Asus actually fix the issue, if you could do the same actually that would be great, here > https://www.amd.com/report

I have already tried contacting Asus twice and have been ignored both times, so... yeah... if anyone from AMD see's this, please help xD
   
Reply With Quote
Old
  (#36)
Alessio1989
Master Guru
 
Videocard: Two different furnaces
Processor: It's getting old...
Mainboard: A voltage leaker...
Memory: Heap corruption
Soundcard: It's over 109db!!!!
PSU: Finally, a quite engine
Default 05-20-2017, 00:04 | posts: 708 | Location: Good-food-land

SM 6.1 will add barycentric semantics. All AMD GPUs support that (actually it is exposed via AMD proprietary extension).
   
Reply With Quote
Old
  (#37)
passenger
Master Guru
 
Videocard: Sapphire RX580 8GB
Processor: AMD FX6300 @4.5GHz
Mainboard: ASUS Sabertooth 990FX 2.0
Memory: 12GB
Soundcard: X-Fi Titanium
PSU: Corsair HX520W
Default 05-20-2017, 02:13 | posts: 237

Found some more goodies in 17.5.2!! this driver won't apply any override AA settings and memory clock is stuck at 2000MHz, yay
   
Reply With Quote
Old
  (#38)
Virs
Master Guru
 
Videocard: R9 390
Processor: Intel Core I5 4690k
Mainboard:
Memory:
Soundcard:
PSU: 700W
Default 05-20-2017, 02:22 | posts: 164

Quote:
Originally Posted by KissSh0t View Post
How would I contact AMD about issues with the ASUS ROG Radeon RX 470 Strix Gaming OC 4GB losing connection to monitor at default clocks when playing video games?

I remedied the issue by underclocking and undervolting, but I would like to have the issue fixed properly by Asus via a bios update, I am unable to modify the bios of this card.

How do I contact someone at AMD that can get something actually done about this? I have tried contacting Asus twice but they basically ignore any type of actual request for help, I am hoping getting someone from AMD to bring up this issue with Asus will get something going with this issue that plagues this specific video card model.
I contacted multiple AMD twitter accounts about this issue and gave them links to this forum where multiple users saw a similar issue (across multiple cards). No answer.
I've been filling bug reports through the driver option for months now, left them my email, no changes in drivers and no email. At this point I don't expect anything to happen.

I have the same issue with a MSI 390.
   
Reply With Quote
Old
  (#39)
KissSh0t
Ancient Guru
 
KissSh0t's Avatar
 
Videocard: ASUS RX 470 Strix Gaming
Processor: AMD FX 8320
Mainboard: ASUS M5A97 R2.0
Memory: G.Skill Ripjaws X F3 8GB
Soundcard: X-Fi XtremeMusic
PSU: Corsair HX650W
Default 05-20-2017, 02:57 | posts: 5,088 | Location: 0.0.0.0

Quote:
Originally Posted by Virs View Post
I contacted multiple AMD twitter accounts about this issue and gave them links to this forum where multiple users saw a similar issue (across multiple cards). No answer.
I've been filling bug reports through the driver option for months now, left them my email, no changes in drivers and no email. At this point I don't expect anything to happen.

I have the same issue with a MSI 390.
I tried contacting this individual via private message https://twitter.com/gchip I can see that he has replied to someone 9 hours ago so yeah.............................

Maybe Hilbert knows someone who could bring this issue to AMD's attention, or Asus.

Last edited by KissSh0t; 05-20-2017 at 03:05.
   
Reply With Quote
Old
  (#40)
ninja750
Member Guru
 
ninja750's Avatar
 
Videocard: Sapphire R9 380 Dual-X
Processor: Intel i5 4670K
Mainboard: Asus Z87-A
Memory: 8GB Corsair Vengeance
Soundcard: Realtek ALC892 DTS Live
PSU: Cooler Master SP M2 520w
Default 05-20-2017, 09:26 | posts: 64 | Location: Italy

just installed 17.5.1 due to the bad report here for tomb raider BUT.. in other forums happens and happens again and again that somewhen windows 10 creators install itsself without prompt 17.1.1 even if there are installed later versions, i was on 17.3.2 and i found magically installed 17.1.1 after a month or so.. so be careful

in other forums just happened this to 3 users.. is it amd related or ms related in your opinion?
   
Reply With Quote
Old
  (#41)
Rootax
Member Guru
 
Videocard: Radeon Fury X
Processor: I7-5820K@4.2ghz
Mainboard: Asus X99-A
Memory: DDR4 4*4GB
Soundcard: CrystalSound 2 / ALC 1150
PSU: FSP AURUM PT 1200W
Default 05-20-2017, 09:30 | posts: 101 | Location: Paris - France

Quote:
Originally Posted by passenger View Post
Found some more goodies in 17.5.2!! this driver won't apply any override AA settings and memory clock is stuck at 2000MHz, yay
I think it's the same bug that 17.5.1 had, ie not applying any profile override settings.
   
Reply With Quote
Old
  (#42)
Passus
Master Guru
 
Passus's Avatar
 
Videocard: MSI r9 280 (Baked)
Processor: i7 4790k
Mainboard: MSI H97 PC Mate
Memory: 16gb Corsair Vengean 1600
Soundcard: SB Audigy 2 ZS
PSU: EVGA SuperNova 750 B1
Default 05-20-2017, 09:34 | posts: 718 | Location: UK

Quote:
Originally Posted by ninja750 View Post
just installed 17.5.1 due to the bad report here for tomb raider BUT.. in other forums happens and happens again and again that somewhen windows 10 creators install itsself without prompt 17.1.1 even if there are installed later versions, i was on 17.3.2 and i found magically installed 17.1.1 after a month or so.. so be careful

in other forums just happened this to 3 users.. is it amd related or ms related in your opinion?
It is MS fault mate, they will have bundled 17.1.1 with the creators update

it happened to me with a few insider builds, I don't use the test versions anymore but since that after any big windows update i uninstall old drivers first knowing it will install it's own then use DDU after and install the latest
   
Reply With Quote
Old
  (#43)
ReaperXL2
Member Guru
 
Videocard: Asus R9 390 @ 1133/1645
Processor: AMD FX6300 @ 4.8ghz
Mainboard: Gigabyte G1 990X Gaming
Memory: 16G Mushkin BlackLine XMP
Soundcard: Native Mobo 7.1
PSU: Corsair CX750
Default 05-20-2017, 14:27 | posts: 122 | Location: Manchester, UK

Quote:
Originally Posted by OnnA View Post
Today was a good day ... until i've launched Forza H 3
Yeah 530Lev -> Forzathon is completed now (Porshe Carrera GT )

OMG

New Win_X CU = Rewriten Driver for WDDM 2.2
ZEN Launch
Preparing VEGA and Vega Pro



But to stay Positive ! we have at last new WDDM 2.2 Working 17.5.1


Wait what !!! There is a working 17.5.1 driver Where can I find this? or have I misread?

Fyi: I, like yourself, am disgusted with regard to the FH3 debacle. MS & AMD should hang their heads in shame !

DX12 !!! Sh*t, FH3 should fly given that MS is the birth mother of dx12 & amd the father of related native hardware support... Sheesh

Last edited by ReaperXL2; 05-20-2017 at 14:51.
   
Reply With Quote
Old
  (#44)
passenger
Master Guru
 
Videocard: Sapphire RX580 8GB
Processor: AMD FX6300 @4.5GHz
Mainboard: ASUS Sabertooth 990FX 2.0
Memory: 12GB
Soundcard: X-Fi Titanium
PSU: Corsair HX520W
Cool 05-20-2017, 14:32 | posts: 237

Quote:
Originally Posted by Rootax View Post
I think it's the same bug that 17.5.1 had, ie not applying any profile override settings.
It's better to go back to whql 17.4.4 until 'graphics division' get their sh't together. Many bugs it's like one person workin' in there, they really need to ryze up their game.
   
Reply With Quote
Old
  (#45)
Dch48
Maha Guru
 
Videocard: Sapphire Nitro+ RX 470 4g
Processor: AMD FX-6300 6 core
Mainboard: Gigabyte GA-78LMT-S2
Memory: Corsair XMS DDR3-1333 8gb
Soundcard: Realtek 7.1 integrated
PSU: LEPA 650 watt
Default 05-20-2017, 15:03 | posts: 1,818 | Location: Upstate NY

Quote:
Originally Posted by Romulus_ut3 View Post
So, there's absolutely no reason for a HD 7000 owner to download this, right? I don't have Prey, btw.
No reason unless you have R or RX series. 99.9% chance it won't improve anything for 7000 cards.
   
Reply With Quote
Old
  (#46)
Chastity
Master Guru
 
Chastity's Avatar
 
Videocard: Sapphire Nitro 390 BP
Processor: Intel i7 950@4GHz
Mainboard: Rampage III Black X58
Memory: 6GB Dominators 1600
Soundcard: X-Fi USB HD
PSU: CM Silent Gold 1200
Default 05-20-2017, 15:05 | posts: 587

Been playing SWTOR as of late, and the in-game AA options are performance hogs. Using driver overrides works very well in alleviating this bottleneck, which, unfortunately, do not work since 17.5.1.

I've gotten around this by using VSR @ 2880 x 1620.

I've submitted bug reports to AMD about this.

On another note, for people looking for help with Strix BIOS issues, you should try contacting Gary Key. He's Asus' Technical Marketing Manager and is more responsive to such issues. I was with Asus Customer Care, and I know that the current Asus Customer Support is inadequate for handling this, as they're a 3rd party contractor. Customer Care division no longer exists, and we would have been the ones to handle this kind of issue, as we could report it to the TPM's, who would then confirm and notify the engineers in Taiwan. Gary Key also has direct contacts with AMD and could get the ball rolling on this too.

Sorry, but I can no longer help out like I used to.

Last edited by Chastity; 05-20-2017 at 15:12.
   
Reply With Quote
Old
  (#47)
OnnA
Ancient Guru
 
OnnA's Avatar
 
Videocard: Nitro Fiji-X HBM 1150/570
Processor: ZEN x8 k17 + Nepton 280L
Mainboard: ASUS Crosshair VI Hero
Memory: 16GB 3200 CL15 1T Ripjaws
Soundcard: SB-z Nichicon + Wood 5.1
PSU: Seasonic-X 750W Platinum
Cool 05-20-2017, 16:00 | posts: 3,131 | Location: HolyWater Village

Quote:
Originally Posted by ReaperXL2 View Post
Wait what !!! There is a working 17.5.1 driver Where can I find this? or have I misread?

Fyi: I, like yourself, am disgusted with regard to the FH3 debacle. MS & AMD should hang their heads in shame !

DX12 !!! Sh*t, FH3 should fly given that MS is the birth mother of dx12 & amd the father of related native hardware support... Sheesh
That's why i said: really ATI
It's a god da!mn shame

But we have to forgive them, becouse:
1. ZEN (it is really good)
2.Vega will have good drivers at launch

But shame is shame - period!

17.5.1 is still live IMO [for Fiji HBM is one of the best WDDM 2.2 drivers now, all is working for me NP]
Here -> http://support.amd.com/en-us/downloa...064&rev=17.5.1

Last edited by OnnA; 05-20-2017 at 16:05.
   
Reply With Quote
Old
  (#48)
ReaperXL2
Member Guru
 
Videocard: Asus R9 390 @ 1133/1645
Processor: AMD FX6300 @ 4.8ghz
Mainboard: Gigabyte G1 990X Gaming
Memory: 16G Mushkin BlackLine XMP
Soundcard: Native Mobo 7.1
PSU: Corsair CX750
Default 05-20-2017, 16:40 | posts: 122 | Location: Manchester, UK

Quote:
Originally Posted by OnnA View Post
That's why i said: really ATI
It's a god da!mn shame

But we have to forgive them, becouse:
1. ZEN (it is really good)
2.Vega will have good drivers at launch

But shame is shame - period!

17.5.1 is still live IMO [for Fiji HBM is one of the best WDDM 2.2 drivers now, all is working for me NP]
Here -> http://support.amd.com/en-us/downloa...064&rev=17.5.1

Ok, thanx dude I'm on the same page as you now
   
Reply With Quote
Old
  (#49)
Passus
Master Guru
 
Passus's Avatar
 
Videocard: MSI r9 280 (Baked)
Processor: i7 4790k
Mainboard: MSI H97 PC Mate
Memory: 16gb Corsair Vengean 1600
Soundcard: SB Audigy 2 ZS
PSU: EVGA SuperNova 750 B1
Default 05-20-2017, 19:20 | posts: 718 | Location: UK

Quote:
Originally Posted by Dch48 View Post
No reason unless you have R or RX series. 99.9% chance it won't improve anything for 7000 cards.
Me him basically have the same card 7950=280 and i see improvements in new drivers so why wouldn't he
   
Reply With Quote
Old
  (#50)
Undying
Ancient Guru
 
Undying's Avatar
 
Videocard: R9 280X Vapor-X
Processor: Intel i5 @ 4.8Ghz-1.38v
Mainboard: Gigabyte Z68XP-UD3P
Memory: HyperX 16GB @ 2133Mhz
Soundcard: Realtek onboard
PSU: Tt ToughpowerXT 775W
Default 05-20-2017, 21:09 | posts: 9,667 | Location: Serbia, NS

Quote:
Originally Posted by Passus View Post
Me him basically have the same card 7950=280 and i see improvements in new drivers so why wouldn't he
Exactly.

AMD didnt drop support on gcn1.0, yet so just update your drivers.

If we had no improvements the 7970 would not be this far from his Kepler competitor.

Last edited by Undying; 05-20-2017 at 21:13.
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com
Copyright (c) 2017, All Rights Reserved. The Guru of 3D, the Hardware Guru, and 3D Guru are trademarks owned by Hilbert Hagedoorn.